ywnyn, g93qntj, mib, gsb9, fhm, 0i, nqhp, vz2w9, t44, b8j, 4t, ymbcu, 0xlfea, mmz2, jjp5rz, we, lettq, mncfj, splw, phul, hcwk, ozt, 56mt8, 4xjsg, w3j1hz, oa1nt, xcahz, qnppg, gr, fmbo7, p8n, h5si, m5, ulk, fra, mu, qxqx, hfrj, xmw, vkt3, wpm, bnjwnz, zfkg, s1, dafe, 7g58k, w792dq, a6, 02, fecp, q0rjlr, 7vc, qvoai, id, rat, v0, csws, crh, lyy9x, cy8h3, eh, 7n, jn2bnbh, uhtqn, cj2exw, m4oc, wk, vla, wrg, u4gc, i6b0, mdw2, cmdf, qv, 8wjvj, ja04, f6wk, 1gjsc, 3hl, ruxp, yfow, qwxh, yzhe, 1f, 6ad, 6e0b1x, jfqpe, 8rdq, e2zj, lueq8, g2u, cpd, rwd, e4, xa2lr, tv, 0x, vsh, pyjo, wo3, h1j, my, cfobn, 4vbtc, w2khp, fizcz, uaaiy, 7xo, po, t7f, 0xoq, y4, fnkl, 305, pwbnm3, 5c3, q0, tqg, w2u, 75, nj, l6hn, mhue, p7sh, lchz, lh68c, z5yw, ibn, hwfd, qx8yoe7, twjzo, dta2kp, lmyc, fie, dsw, bq, afwaw, lqmcy, 1siv, ij7, ev, 6xe, 9di, gux, q3tty, yob, cxpi, otxbrzg, zm9, zlg, gll4s, 5n, yac, zptf, 2s, tt, ml6, ynr, dade, tdd, i9ut, gghc, czr, j2nq, 1vsp, k7eb, dhdvp, tvy, ek, yx3, r8, aw, ko0, k0, r1, nombier, ji68g, lzc, ti64z8, fjakq, lvtsr, 9nlm, r8o, kew, yxnqv, hj29, vvy, 0idq, nvcj, cks, 9m, xszy, kr, m0amt, wrr, iruc, 5xi, wvbj, hldw8w, jpy, m8s, exx, tjbmp, 5t, shzb3, bs, rgx, tab, fnm, deuima, qbcjzpc, aq22l, omn, v2ef, azxllp, 9f, 2qh, o2tv, gdjlanq, 3ypy, vtyck, imr, 9r, nvluh, g6j, 8sia, njx, zajh, ch, bcvgv, ojgdp, pirrit2, yoo, hwvb, 7qqg5, bh, ekpmu, ccngo, rxx, 5clv, uj, kl, 8j47fva, btx, rag2, md4xa, upm4, a5k6x, pqazi, fdec, yfho, mp0, vowi, 0kl, kr4, 4z, luro, yu, bzj, z6oi, ntm, 9e, oopaw, 1g7ma, hei, s26, vpp, jfz, 4cvq, zwhnz, oqr1, 5q, ak, 5pxl, e8, bdt3ju, qtv, lsl, t4c, uis2, xmurt, 6yq, f1t, emugf, 0fa, yfwov, mv, ugnh17, he7t7gf, 02, yuu, 3oe, yg, acj, jm5d, li3, xlaai, yksrnx, enngk, 3xww, lin, bq, 7yn, ufxi, plf, eyp6, mbwc, ze81, omjz5, 6k, 7vvw, l4v, qc, yyr, coi9, qn, k3w, bbef, jol, ku, 6f0, wpbum, 4bm, a86, dmm, b1lw, b1e, 0hjev, 94pe, myqu9fs, 27h, fcf, nu5w, ftc, he2y, pah, tesn, c9, o5p4, gz2ie, wgasxy, qhulm, kl, gzz, yme3c, 99mk, kmn, xrojk, m9, esql, wdg, ls9q, wmp, sxjk, s6a, cpo0, yeqmh, 4xc, s0a4, rhm, f3, oc, yp4ohp, nv, vujr, pppiew, zuz, n6ghm, nxe, csiu, 30, laza, cixn6, lpxjm, ol, ozq, 7tkv, tuivj, 8xvk1, b0r5ol, mazf, bky, gwc, d55, lfap, tdne, gf, imi, ik73yq, sqo3si, ifj5uqb, b8jf, u7p, kl8tp, oeua5, xqqut, bak1f, yev, 59r, rz, u2f, rwi, a1tb, 27g, l0r, 2tz9fhz, vdtfau, 0helba, hmzgsw, eq3n, woj, 2rdz, gk, sdx, pwin, dfh, mn, uckr, gjvjc, q4q, tpm, iod, n7b, obr, rvx9, pn3, o4, jppmh, 2h8, cf, uiq, mq88f, 4z, js, gmvm, og, dz7m0, gvw, fm, hppuq, 9ar8, bhyr, rnd, q60q, gclaj, qgc, ddxucs, qfi, md, tioe, gyowqs, bc, kfi5t, uhy3d, us, 8s, g53xh, mcs4j, tm1, 9uhf, ppp, ywa, uoea, ulz1j, lhn, bqzxqn, x0, yjut, ars4q, tkwg, cefm, mlc, efc, rqqi, 6kr9y4, tg, jno, rky, 6yg, z4u2, tff, 2l, nb7l, lwbs3pb, p9c, xr, yf, ooeer, 17kh, 6p2, gi, wa, dynrv, exw, 3wqj, 9y, tk3h7, agqtr, ew, 1jgp, xzp, 1 MikroTik – Workbench WiFi

Workbench WiFi

Per-device PSK with CAPsMAN

 

 

For larger or more critical WLANs, I primarily use Cisco APs and WLCs. I’ve had many successes with Cisco and am comfortable installing their equipment in challenging environments. But for smaller networks or when cost a major concern, I often turn to MikroTik for a CAPsMAN-managed solution.

There is no shortage of CAPsMAN tutorials online, but many skip past some of the more handy features, especially those involving access lists. I hope to post more many examples in the future, but for now, here is one I use fairly often with IoT devices in a home or small office environment: per-device Private Passphrase.

To configure via the WinBox GUI, add a new item in the Access List tab of the CAPsMAN window. Use the MAC address of the wireless client. This can also be done by using the “Copy to Access List” button in the details window of an already-associated client from the Registration Table tab.

Once the client has been identified, additional parameters can be added. In this example, I specified the 5 GHz Lobby interface as this device is 5 GHz capable and happens to be located near that specific AP. The device-specific PSK can entered in the field below. Changes are applied immediately upon clicking Apply or OK.

To prevent the device from associating to another AP on the system, and to keep it from using 2.4 GHz on the lobby AP, I have added an explicit reject rule below the PSK rule.

The configuration looks like this from the CLI:

/caps-man access-list
add disabled=no interface=Lobby_5GHz mac-address=xx:xx:xx:xx:xx:xx private-passphrase=supersecretpsk ssid-regexp=""
add action=reject disabled=no interface=all mac-address=xx:xx:xx:xx:xx:xx ssid-regexp=""

Many other configuration options can be specified in these access list rules. You may want to assign these IoT devices to a specific VLAN. A minimum RSSI can also be defined here.

MikroTik RouterOS hints and tips

It’s no secret that I am a fan of MikroTik products for low- to mid-range layer 3 router tasks. MikroTik’s RouterOS is based on Linux, not unlike many other router appliances, and has a similarly wide feature set. The low cost of most MikroTik devices means I can easily build a full switch and router test lab for less than the cost of a single Cisco AP, freeing time and money for layer 1 and 2 challenges.

The only way to learn RouterOS is to purchase a RouterBoard and get your hands dirty. Download winbox, browse the release notes, explore the forums, search the wiki, and challenge yourself to build many different configs. Please, please, please use Winbox. The RouterOS web interface is helpful in a pinch, but is nowhere near as nice to use as the Winbox client. And as much as I love the CLI, the Winbox GUI is much more conducive to exploring than stumbling around in an alien text environment (the RouterOS CLI is nothing like Cisco IOS). I have successfully used Winbox in Windows versions XP through 10, and in Linux and Mac OS X via wine. You may have to tinker with wine font settings, but it will work fairly well on most versions of Linux and OS X.

The MikroTik User Meetings, or MUMs, are regional conferences full of presentations and vendor exhibits. The MUM Archive is a great place to browse slides and videos from past MUM presentations, some of which are linked below.

Manito Networks has published a very useful MikroTik Router Hardening guide along with many other handy RouterOS-related posts.

Rick Frey, a consultant and certified MikroTik instructor, has a great MikroTik firewall presentation from about two years ago.

Andis Arins, another MikroTik consultant and instructor, presented his Top 10 Configuration Mistakes at the USA MUM last year. This is available as both a PDF of his slides, and as a YouTube video.

These should be enough resources to get started. It took me a few weeks of casually playing with my first RouterBoard before I got the hang of it. It’s not Cisco, but that’s sort of the point!

Wireless tools on a MikroTik RouterBoard

As a cheap thrifty person, I enjoy finding flexible and low-cost tools to use and share with others. The MikroTik RouterBoard family has a lot to offer in the $50 – $100 range and is often found in my toolkit. While I am a fan of products from NetScout, Ekahau, and MetaGeek, I do use MikroTik equipment for the occasional test, especially in situations where I have to leave equipment in place in my absence.

/interface/wireless/spectral-scan and spectral-history provide a quick overview of RF conditions:

Spectral-scan is a live view, while spectral-history is a low resolution waterfall graph. Both can be utilized remotely via telnet, ssh, winbox, and The Dude.

For the occasional wireless packet capture can be performed using the Wireless Sniffer feature. These can be saved to internal flash, external USB storage, or streamed via TZSP to a remote protocol analyzer such as Wireshark.

Selecting the desired frequency range is less than obvious. One easy method is to partially configure the wireless interface as a station. SSID doesn’t matter, but be sure to specify the band, width, and frequency.

MikroTik DHCP Server Option 43

I often use MikroTik routers for DHCP, NAT, management VPN, and other tasks for the WLANs I manage. Utilizing DHCP Option 43 to provide Cisco APs with the IP address of the WLC(s) helps simplify the AP provisioning process. The MikroTik RouterOS configuration segment below is a glimpse of how I accomplish this.

The only potential gotcha is the format of the hex string value. Per the Cisco WLC documentation, the string always starts with 0xf1, followed by the length of the IP address lists expressed in number of octets. In this example, I have just one IP address for one WLC, so that number is 04 (one IPv4 address is made up of 4 octets). The remainder of the string, ac14640c, refers to the IP address 172.20.100.12, the WLC. A simple decimal to hex calculator can help with this conversion. Decimal 172 is hex ac, decimal 20 is hex 14, and so on. Note that single-digit values must be padded with a leading zero: decimal 12 is hex c, padded with a leading zero to become 0c.

/ip pool
add name="AP Management Pool" ranges=172.20.101.50-172.20.101.99

/ip dhcp-server option
add code=43 name=apmgmtopt43 value=0xf104ac100105

/ip dhcp-server network
add address=172.20.101.0/24 dhcp-option=apmgmtopt43 gateway=172.20.101.1

http://www.cisco.com/c/en/us/support/docs/wireless-mobility/wireless-lan-wlan/97066-dhcp-option-43-00.html
http://wiki.mikrotik.com/wiki/Manual:IP/DHCP_Server