Workbench WiFi

Cisco Wireless Software Versions

Navigating the many versions of Cisco wireless software can become a headache. I often use the newest versions, especially when working with the latest Cisco APs (such as the new 2802i). This is not always practical or possible, especially when working in an existing environment where specific versions may be required for compatibility or stability reasons. The Cisco Wireless Solutions Software Compatibility Matrix has cross referenced lists of AP, WLC, MSE, Prime, and other related component versions.

Another helpful resource is the list of WLC versions supported by the TAC, along with brief notes on each.

 

MikroTik DHCP Server Option 43

I often use MikroTik routers for DHCP, NAT, management VPN, and other tasks for the WLANs I manage. Utilizing DHCP Option 43 to provide Cisco APs with the IP address of the WLC(s) helps simplify the AP provisioning process. The MikroTik RouterOS configuration segment below is a glimpse of how I accomplish this.

The only potential gotcha is the format of the hex string value. Per the Cisco WLC documentation, the string always starts with 0xf1, followed by the length of the IP address lists expressed in number of octets. In this example, I have just one IP address for one WLC, so that number is 04 (one IPv4 address is made up of 4 octets). The remainder of the string, ac14640c, refers to the IP address 172.20.100.12, the WLC. A simple decimal to hex calculator can help with this conversion. Decimal 172 is hex ac, decimal 20 is hex 14, and so on. Note that single-digit values must be padded with a leading zero: decimal 12 is hex c, padded with a leading zero to become 0c.

/ip pool
add name="AP Management Pool" ranges=172.20.101.50-172.20.101.99

/ip dhcp-server option
add code=43 name=apmgmtopt43 value=0xf104ac100105

/ip dhcp-server network
add address=172.20.101.0/24 dhcp-option=apmgmtopt43 gateway=172.20.101.1

http://www.cisco.com/c/en/us/support/docs/wireless-mobility/wireless-lan-wlan/97066-dhcp-option-43-00.html
http://wiki.mikrotik.com/wiki/Manual:IP/DHCP_Server

Cisco WLC 8.3.110 beta

Cisco has posted information regarding the next minor update to the WLC 8.3 release trains, 8.3MR1 aka the future 8.3.110. This new release, currently in beta, adds support for the new 1560 outdoor 802.11ac Wave2 AP and brings the Apple optimizations to the newest 1800/2800/3800 indoor APs.

Additional details and contact information to participate in the beta can be found on the following forum thread:

https://supportforums.cisco.com/discussion/13136886/83mr1-beta-availability