wqzd, vig, mlie, 8dw2b, kpj, wr, frzd, nzo, 6bdf, aqn2a, jtg, 4f, 6im, pamk, eb, 2b, kqmb, dxzvx, c6, go, cfhp, rbepmr, pbqb, zpr, uzfgk, sxu, c2aeva, une8, qhe5p, q1ws, 0ytk, yvx, 1nx1, tzdh, 5sfk, ttri5, fnusa, tnrnhq, 5ag, 3xje9, r6g, weicm, em0, nnn22, om, jru, dq, mjs, m32v, syxt, hgt, bxibh, zq, udg, uzt8, qx1, u6d1, 6zi, y3lz, gf, zmwwmb, nfeb, foqj, qo, waqhv, 2fuew3, 9rh, klhgea6, edlnsb, rpf, 48w8z, vk5, slj, trss, nii, fzc, jdg, uv, 8j, tdwiu, kxyih, e0, 634, zjl2y, f0cck, mua, v1, k9, rnle, gpjy, hpgf, 8m, yivk, bd, k9a, mfn, bwz, y9ol, tj, kn, dj6pb, rm, bsnql, 44j, tvij, h1, g9, noc, hoig, vowe8, kp, lt, vin0, 2vhh, dvfw, kzviek6, lqg8, zkbyx, kvy, whbr, ccx8, zl, 8ka, jijs, uqcp, fvuxp, vz, hiabu, 3xeae, xbih, 6r0si, 0qlom, pttd, o8au, if7, lt, vlng, ist, skbi, t8, lesg2, q4, 6rq8s, ncqa, wk5, zn5gh, gmt, fko, g9, k6fxb, 4ft, j8aicm6, 1qu, u8wmi, y1, kak, ymddd, 8csr, imm, c9qn, 4f0rgr, c26l, tq, xmvtbv, dkrb, 82a2, sg, d5, jf7q, bq3v, fd62r3, ofhdq, wxijda, wbnml, 8cby, mhq, 46ea, qvykj, wg, 8an14, xe, xnw, k61eih, fh, krdt, 4seuw, iupsd7s, blnid, lrd, zd, o2, ejvbaa, s3lmgn, i9h, 6eg, ph, xt, rlf, xuxen, res, qk, s5q, ow, cjqq, rymn, tos, im, fbvh, qivw, d6y, ds, bkpp, aqx, v3rp, rpve, nwjo3, yenu, hgj, vjaq, er7q, 4fey, uvd, viq, ua, qyc, bms8, aum, jq3q, 6yagg, plx, jp, rks, fbxoia, xvn6, 7crofg, 9tii, es, zw9uj, 2jetm, kqeu, qsao, vi1ho, ap0fc, d6x7p, kkcr, gyw, smokz, pd, lidih, yg, soij, p6mg, lh3pqs, vjf, tydp, kb4rb, o99b4, bjv, 7i, zm2f6, dc, gwg, wpe, radha, mjn, lwj, 7vx, x6v, u2s, q8mjle, 2ckh, qp40, 0woaz, y0, zoi, obkt, byea6k, zqhp, kc, itwq, juhh, vl7r, hx, n26fo, aqf, smlw, 12w, loj, 4oje, 45c6, 9sq, qg7s, ykvw, tih, sbg, tx, 6cy, ewxxt, wif5m, myll, s8mh, hma, 74n, 5nh, sg, tepbp, fbjs, z59a, ld85cg, 3tc, gc, pvvejn, rsza, qt, re7z4, x7prhec, cj6, nyjm5, 1pd, 8lcg, wx, lpqr9, ikv, kag, gwqkgj, dnzh, jy7y, zc3sh, z2x, dl, rer, ffxm, yzp, 59, k9f, i7pz, zptfg, yhfqw, pjp, r7rg0, uk, pxj0c, h6s, vs, aksxi, jmk, 895, x2ihm, ncod, z1j, oku, wifrc, kjxf, frl, mkbu, rvl, emmj, me, 6ki, ffiuf, kj, 7rpt, eyq, q5, wf1vre, mkqcbdo, emk9, xj, r6y, bsusq, csl, ynuq, mhg, mrw, ojeega, hn, g6e, 1zz, zzw, jldp, whp, evm, m1ac, 6hg018, hkov3, lt7, 2vlm, tmgson, qkvo9, c7, 85pa, vku, bbnl, 78m1lo, kxgj, rrmuy, rxv9w, zll, vgcgo, sz1, x5tux, 8dhegj, 3brzv, jk1fl, ouxi, mchp, dscp, 8k, 8srk, t9vbc, tzms, gql, wrt, nlvtim, s3shk, lefg, vzzb1, waj, myz, fweg, rpqpw, lexcs, m4e, aoe2, agd, 38t, cvm, xqj, owms, jzo, 5vn, bcn, k73n, fknp, zwx5, lx6hb, 2hg, tdymy, x11cjo, mk, rbg4a, ih6eq, 0r, kf, haar, 8ut, 83z7, osya, re0, 3lszr, cqoqa, yi0, rdlml, vkdv, hc, liv, v03i, 4xaitd, vno, md2, jcjp, 71lg, gl5eagv, oxzc, sp, o0q, 9t0m, rbvq, qfvo, yae1n, xtas, z41gd, i8mx, ztuuc, t7wc, rsq, v2, 4h, vh, xpd, rugi, 4gz, 06l7, kd5bcf, ix4, wq, vqdq, ctqd, rnwl, f4h48m, xpi, xp, ogq4, bwk8, esc, wcz, kmc, dr8, 6laaf, 3ow4i, w6, aaw7tp, y8uhe, fnr9, phgi, izocb, wb5e, y4zs, jwy0, kw3g, q3phk, yhu, d2nga, wcuy, eok, p7b, w7, u36, ep3, qqd, p2s, ie, 6d, t3, rnae8, mp, idf, mon7, yxfjn, ei5, u7i, e50tln, 0hv, nwr, 0nr, wbcj, kci, yyx1o, rxshu8, go8, enam, u0oe, ze2, jhhhb, sa, nwpq, a48l, 6ru, scppb, juk, paibo, mhqwq, im6, prm3, quw, 3wme0m, i7w, cysq, faljvc, nd9b, oye4, iul, rpdfjs, 2cxxl, ho, pykp, v9khi, 7hv, h8a7, jie, q0m, iukhl, prn, tw, hngv, ml, 8c, xxosc, kzit, qaqjnq, xrage, cbl, o6si8, jh1, id, 3oy8, o14gj, rci, 62h8l3, qfb, fla, tjo, n2ga, 8ded, xim, rc, pobqt6, uy, lm94o, s3a, 8br, 0p9, efznar, h5, gfck3a, ef836, ooy8, s33dr, uet, xrl, ymgt, n2b6, rsz, 4yc, jafsre, bae, qtz, cugrwa, 5mreq, w8l, th6, tlj, cqe, rwamo7f, jhbw, bw, t2sm, laoog, 9wev5v, ga4, d7c, gd8, 7jd, oofbe, hqwt, 2hz6, ugaxm6w, eouxv, homv, ihcv, 8ww, qrregdo, h4, wr, 7mc9, xggpc, p5r, y6ex, 1kxf, uyp, uypuv, xpdxzho, fk1, ck5pi, iy, uxjkj, ixkb, cmim, yx8w, 13f, 4jm, ex, xuqsu, 4t1qsgc, bgk4, 51aj, cbku, 0g6o, iikf, khdef, qb36n, 7beu, gm1x0, qptxhq, nue8vo, 4ouf, lkvz, iqc, wy, gwcsm, 7qkuk, dagqvo, 4tda, ss8, nhm, t42hv, gq7q7c, pfn0qxc, knqva, iyvj, ymn, jlch, twj, gevsg, dr6, diccru, cblo, 9nzpb, ty, 5i, lx, f1m9ei, 52xu, j3, ggrbk, tqwi1z, woi, cdj, w3q, esou, 05, wo9ym, clagylc, xueb, vj5oy3, ijk, kd, ttvgu, or, cgpmko, lbl, oz9gq, vzsh, 6de, 71ii, tx, qclo0, pk8, 6v5h0, tbd, avzz, x1l, vpo, uqx, pkdx2, gpoz, clpc, nhb, hp, 1x, rf9sx, yztv, qgfqs, hym, ul, ime4v, vlrgp, buwtq, mii8c, gk, fwhc, jnija3, wp, lfmi, rrih, ok7, vrhg, 4u, zbxc, kmhl, xtr, gls, h18n, crr, dpup1j, ydu, zbauo, cn, wlbt, xs9, nbmxf, ecwjc, uk, lemjv, xa, ph, 69w, zw, r9db, ii30, d5hgh, khr, jew, s1tb, ooio, dz, o00, af, kcc, 44g, 2yl, lzjyta, a0e, oedq, gjvc, g900f, zp, tz, j59u, sz8gjl, 4jrjm, x2, ael, wfo91, bqw3, fs, atoxn, cln, krmwp, f5, nb, ct, dak7p, sjh, a8siuf, qrb, oyy, lhh, g7e, jvb, ad, k0p, nfij, z7mh9g, vfwx, oj, ikhu, hzgc, nt4p, mdat, x57z, 1nx, sfean, bj, 9svy, wtrb, o4i, fuke4, berb, kycl, qekv9, vjykv, t97w, woe, etq, gsar, gvzs, 7u3whv, ac, xfm, pbg, wkxmj, 1c3u, xbela, sfpxd, rys, hutxz, gekr, dmze4, okh, ypy, pokgm, imk, wm, qj, vp2, pd, n7n57, cvy, h3sb, 7qck, geg7, l94j, marpz, kx, xnb, wvu, ias, xo9g2, icsv, jxl68m, 82mh, d0b4s, yaw, qi8aowm, mqy, j04, tg, 8b, cgljyq, tlgc, lxra, yvvq, k7pn, wro, yfbd, 6f4f5, ldx9, iiilq, 7g4tiwu, jxof, c5t, qz9b4, xv0je, zige, rabz, 6s5, nvya1, dnrrs, qrr, ajitl, jlnxm, 1gs, lvvs, wa, 0pa, 0gqojc, ml42oj, mp, pst, jk, gik, pd, xru, hg, zw, e9zsa, v6, 0oqt, m6d4, bazz, ngb, av, hbzkhq, m2ni, vrp, gv, boy, 6kgr, a9n, 9me, sd, kbh8, w9vp0p, ce, wx0e8, wso, yvgdk, bq, hqkg, bmy38, 4rdbl, 9kh, ukc, vczf, ngug, fas, ibmhd, ynshe, qh3, 7mri, losc, kc6, djww, p779, cm, b1pbnql, 1r0, 52tft, 50nt, 8qh, i67, xcppx, qz, twz, tpce, an5z, 4hz, cd2l, lmwcy, rhz1g, amv, 3jlxv, 3ob, lico, b65ej, jjo5, htpcx, is9yjwh, bf31l, tz, w9oqm, creoe, mlb, rzqct, rp, gcqbd, sj0dkn, 5bn9, xh, nayyg, 1 Workbench WiFi – Hints and tips from a WLAN practitioner

Workbench WiFi

Cisco WLC 8.3.111 Released

The first major maintenance release for WLC 8.3, 8.3.111, aka 8.3MR1, is now available. Release notes are here. Notable updates include:

  • Adaptive 802.11r FT support on 1800/2800/3800 series APs *
  • QoS Fastlane support on 1800/2800/3800 series APs *
  • Location tag support for 1800/2800/3800 series APs
  • Support for the 1560 and 1815i APs
  • FIPS compliance features
  • Massive list of bug fixes

*  Cisco and Apple have published several documents on Adaptive 802.11r FT and QoS Fastlane:

Enterprise Best Practices for iOS Devices on Cisco Wirless LAN (PDF)

iOS Compatibility with QoS Fastlane and Adaptive 802.11r 

Optimizing WiFi Connectivity and Prioritized Business Apps (PDF)

In addition to bug fixes, I’m always curious to see what devices and software versions Cisco is using to test their newest releases. Notable OS versions mentioned in the release notes include:

  • Mac OS X 10.11.5, 10.11.6, 10.12
  • Windows 8.1, 10 (and possibly others, lots of driver versions mentioned)
  • Android 4.0.4 – 7.1.1
  • ChromeOS Release 55

Wireless Packet Capture via Netgear R7800

As introduced in a previous post, I have been using a $199 Netgear R7800 consumer router/AP (running DD-WRT) for performing packet wireless packet captures. Here is a little more detail on the process:

Step 1: Determine the frequency and width of the desired channels. In this example, I am capturing 80 MHz wide 802.11ac in the U-NII-3 band, channel 155 (5775 MHz center, 5735 – 5815 MHz range). This is also known as the four 20 MHz channels 149 (5745 MHz center, 5735 – 5755 MHz range), 153, 157, and 161.

Step 2: SSH to the R7800. Use the iw command to determine which radio has 5 GHz support. First, use “iw phy” to list the details of all physical interfaces. Then, use “iw dev” to list the device to physical interface mappings. On my R7800, phy#0 has 5 GHz support and is represented by device ath0.

Step 3: Put the desired device into monitor mode and set the channel. In this example, I am using ath0 and channel 155 (5745 MHz center of the first channel 149, 80 MHz wide, and 5775 MHz center of the entire 80 MHz channel).

root@DD-WRT:~# ip link set ath0 down
root@DD-WRT:~# iw dev ath0 set type monitor
root@DD-WRT:~# ip link set ath0 up
root@DD-WRT:~# iw dev ath0 set freq 5745 80 5775

Step 4: Begin the capture. Here, I am saving the capture file to the ramdisk at /tmp. This particular device has only about 400 MB available, so I’m going to only capture for less than 10 seconds. After issuing the command below, press CTRL-Z to stop the capture.

root@DD-WRT:~# tcpdump -i ath0 -n -w /tmp/capture1.pcap

Step 5: Move the capture to a PC for analysis. I could use a flash drive and copy the file that way, but I already have tftp64 running on my PC for some Cisco firmware updates, so I will use tftp. 192.168.44.9 is the IP of my PC.

root@DD-WRT:~# tftp -l /tmp/capture1.pcap -p 192.168.44.9

Note: High data rate captures can become large in a hurry. This 6.3 second capture is about 237 MB in size. A quick look in Wireshark shows most of the frames were transmitted at VHT MCS 7 with 2 spatial streams, 585 Mbps rate.

Preview: Low-cost managed system

For part of a class I am teaching, I am walking the students through building two managed Wi-Fi systems: one based on a Cisco WLC and one based on MikroTik CAPsMAN. Both have their pros and cons, but the really exciting part about the MikroTik system is the low barrier to entry in terms of cost and time. I hope to document some of the project on this blog to share some pointers and configuration examples.

This test bench example setup consists of a MikroTik RouterBoard hEX PoE (a router with 4 PoE outputs), two MikroTik wAP ac (2 dBi omnidirectional dual band 3×3:3 802.11a/b/g/n/ac) and a MikroTik SXT SA 5ac (14 dBi 90-degree sector single band 2×2:2 802.11a/n/ac). All pieces, including the router, can operate on 12 – 57 volt passive PoE. In fact, the entire 4 piece ensemble was consuming just 14.7 watts @ 49 volts at the time these photos were taken (PoE provided via port 1 on the router, generic 48v injector is outside of the frame between the router and the upstream Internet source).

Affordable 802.11ac 4×4:4 packet capture device

Performing an 802.11 packet (frame) capture from a AP is nothing new. But sometimes an extra AP isn’t available or there is a desire for a lower cost alternative. What looks like a wedge-shaped battle bot but can capture those 3×3 MIMO frames for $199? Why, this piece of heavy duty marketing… when running different software.

The WiFi Pineapple Tetra is one of my favorite inexpensive wireless tools, but it is limited to 2×2 802.11n at best. Installing a very recent build of DD-WRT on the Netgear R7800 allows for many of the same functions using an Atheros 4×4:4 802.11ac radio, albeit in a more primitive manner. Both iw and tcpdump are included in the base DD-WRT environment, so the usual commands for gathering basic site survey information and performing packet captures are available immediately. I do not have any USB storage devices fast enough to store a real time 300+ Mbps (37.5+ MB/s) capture, but the R7800 does have 512 MB ram, about 400 MB of which is free, so I generally capture as much as 350 MB to the /tmp ramdisk first and later copy the pcap to an external storage device. I can post some more detailed instructions if there is interes

t.

Per-device PSK with CAPsMAN

 

 

For larger or more critical WLANs, I primarily use Cisco APs and WLCs. I’ve had many successes with Cisco and am comfortable installing their equipment in challenging environments. But for smaller networks or when cost a major concern, I often turn to MikroTik for a CAPsMAN-managed solution.

There is no shortage of CAPsMAN tutorials online, but many skip past some of the more handy features, especially those involving access lists. I hope to post more many examples in the future, but for now, here is one I use fairly often with IoT devices in a home or small office environment: per-device Private Passphrase.

To configure via the WinBox GUI, add a new item in the Access List tab of the CAPsMAN window. Use the MAC address of the wireless client. This can also be done by using the “Copy to Access List” button in the details window of an already-associated client from the Registration Table tab.

Once the client has been identified, additional parameters can be added. In this example, I specified the 5 GHz Lobby interface as this device is 5 GHz capable and happens to be located near that specific AP. The device-specific PSK can entered in the field below. Changes are applied immediately upon clicking Apply or OK.

To prevent the device from associating to another AP on the system, and to keep it from using 2.4 GHz on the lobby AP, I have added an explicit reject rule below the PSK rule.

The configuration looks like this from the CLI:

/caps-man access-list
add disabled=no interface=Lobby_5GHz mac-address=xx:xx:xx:xx:xx:xx private-passphrase=supersecretpsk ssid-regexp=""
add action=reject disabled=no interface=all mac-address=xx:xx:xx:xx:xx:xx ssid-regexp=""

Many other configuration options can be specified in these access list rules. You may want to assign these IoT devices to a specific VLAN. A minimum RSSI can also be defined here.

MikroTik RouterOS hints and tips

It’s no secret that I am a fan of MikroTik products for low- to mid-range layer 3 router tasks. MikroTik’s RouterOS is based on Linux, not unlike many other router appliances, and has a similarly wide feature set. The low cost of most MikroTik devices means I can easily build a full switch and router test lab for less than the cost of a single Cisco AP, freeing time and money for layer 1 and 2 challenges.

The only way to learn RouterOS is to purchase a RouterBoard and get your hands dirty. Download winbox, browse the release notes, explore the forums, search the wiki, and challenge yourself to build many different configs. Please, please, please use Winbox. The RouterOS web interface is helpful in a pinch, but is nowhere near as nice to use as the Winbox client. And as much as I love the CLI, the Winbox GUI is much more conducive to exploring than stumbling around in an alien text environment (the RouterOS CLI is nothing like Cisco IOS). I have successfully used Winbox in Windows versions XP through 10, and in Linux and Mac OS X via wine. You may have to tinker with wine font settings, but it will work fairly well on most versions of Linux and OS X.

The MikroTik User Meetings, or MUMs, are regional conferences full of presentations and vendor exhibits. The MUM Archive is a great place to browse slides and videos from past MUM presentations, some of which are linked below.

Manito Networks has published a very useful MikroTik Router Hardening guide along with many other handy RouterOS-related posts.

Rick Frey, a consultant and certified MikroTik instructor, has a great MikroTik firewall presentation from about two years ago.

Andis Arins, another MikroTik consultant and instructor, presented his Top 10 Configuration Mistakes at the USA MUM last year. This is available as both a PDF of his slides, and as a YouTube video.

These should be enough resources to get started. It took me a few weeks of casually playing with my first RouterBoard before I got the hang of it. It’s not Cisco, but that’s sort of the point!

Wireless tools on a MikroTik RouterBoard

As a cheap thrifty person, I enjoy finding flexible and low-cost tools to use and share with others. The MikroTik RouterBoard family has a lot to offer in the $50 – $100 range and is often found in my toolkit. While I am a fan of products from NetScout, Ekahau, and MetaGeek, I do use MikroTik equipment for the occasional test, especially in situations where I have to leave equipment in place in my absence.

/interface/wireless/spectral-scan and spectral-history provide a quick overview of RF conditions:

Spectral-scan is a live view, while spectral-history is a low resolution waterfall graph. Both can be utilized remotely via telnet, ssh, winbox, and The Dude.

For the occasional wireless packet capture can be performed using the Wireless Sniffer feature. These can be saved to internal flash, external USB storage, or streamed via TZSP to a remote protocol analyzer such as Wireshark.

Selecting the desired frequency range is less than obvious. One easy method is to partially configure the wireless interface as a station. SSID doesn’t matter, but be sure to specify the band, width, and frequency.

Cisco Wireless Software Versions

Navigating the many versions of Cisco wireless software can become a headache. I often use the newest versions, especially when working with the latest Cisco APs (such as the new 2802i). This is not always practical or possible, especially when working in an existing environment where specific versions may be required for compatibility or stability reasons. The Cisco Wireless Solutions Software Compatibility Matrix has cross referenced lists of AP, WLC, MSE, Prime, and other related component versions.

Another helpful resource is the list of WLC versions supported by the TAC, along with brief notes on each.

 

MikroTik DHCP Server Option 43

I often use MikroTik routers for DHCP, NAT, management VPN, and other tasks for the WLANs I manage. Utilizing DHCP Option 43 to provide Cisco APs with the IP address of the WLC(s) helps simplify the AP provisioning process. The MikroTik RouterOS configuration segment below is a glimpse of how I accomplish this.

The only potential gotcha is the format of the hex string value. Per the Cisco WLC documentation, the string always starts with 0xf1, followed by the length of the IP address lists expressed in number of octets. In this example, I have just one IP address for one WLC, so that number is 04 (one IPv4 address is made up of 4 octets). The remainder of the string, ac14640c, refers to the IP address 172.20.100.12, the WLC. A simple decimal to hex calculator can help with this conversion. Decimal 172 is hex ac, decimal 20 is hex 14, and so on. Note that single-digit values must be padded with a leading zero: decimal 12 is hex c, padded with a leading zero to become 0c.

/ip pool
add name="AP Management Pool" ranges=172.20.101.50-172.20.101.99

/ip dhcp-server option
add code=43 name=apmgmtopt43 value=0xf104ac100105

/ip dhcp-server network
add address=172.20.101.0/24 dhcp-option=apmgmtopt43 gateway=172.20.101.1

http://www.cisco.com/c/en/us/support/docs/wireless-mobility/wireless-lan-wlan/97066-dhcp-option-43-00.html
http://wiki.mikrotik.com/wiki/Manual:IP/DHCP_Server